Results 1 to 3 of 3
  1. #1
    RoadBikeReview Member
    Reputation:
    Join Date
    Jul 2007
    Posts
    34

    Specialized Turbo Elite Cyclocomputer

    I have one of these and have been using it with great care. I just went out on a ride tonight and I cannot get the thing to display mph. It's like it can't read the senor data. I tried various positioning points with the senor and I tried resetting the unit. A quick scan on the web reveals that this is a common problem. Has anyone here experienced this?


  2. #2
    Neophyte
    Reputation: jetdog9's Avatar
    Join Date
    Jul 2007
    Posts
    319
    I'm really liking my new Specialized bike but the Turbo 2 Comp computer I bought for it was so crappy I immediately returned it. Not exactly quality, clearly built in an overseas factory with Specialized's logo slapped on it.

    There was no good way to mount the sensor and the magnet they sent was supposed to work with both round and bladed spokes but didn't work too well on my bladed spokes. Also, 2 of the buttons did not register about 1/3 of the time you pressed them. That's something that would have been frustrating out on the road so I just sent the thing back.

    I do remember that the magnet and sensor really had to be close together to register compared to my old Avocet 45.

  3. #3
    RoadBikeReview Member
    Reputation: InigoMontoya's Avatar
    Join Date
    Jun 2007
    Posts
    6
    I just bought one too last week. The speed transmitter/sensor didn't work when I got it installed, which my LBS replaced. I, too, noticed that the MPH will not work at night. It only works in the day, or when I ride under a street light sometimes

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

EUROBIKE

Hot Deals

Latest RoadBike Articles


Latest Videos

RoadbikeReview on Facebook