Creaky Brooks B17?
Results 1 to 7 of 7
  1. #1
    RoadBikeReview Member
    Reputation:
    Join Date
    Dec 2005
    Posts
    7

    Creaky Brooks B17?

    Just wondering if anyone has any experience with fixing a creaky B17?

    The frame seems to be quite creaky when I sit on it and its driving me nuts ...

    Don't seem to have this problem with my other brooks saddles ... should I tighten the front tension bolt, or can I apply some lube somewhere?

    Thanks!

  2. #2
    RoadBikeReview Member
    Reputation:
    Join Date
    Sep 2004
    Posts
    121
    My B17 recently started creaking too. It was bad for a couple of days, but is now subsiding.

    I would love to hear any suggestions on how to fix it.

  3. #3
    Man, I'm Awesome
    Reputation: brianmcg's Avatar
    Join Date
    Oct 2002
    Posts
    2,175
    Spray some lube on the rails and make sure your bolt on your seatpost is really tight.

  4. #4
    MB1
    MB1 is offline
    Enjoying Post-Employment
    Reputation: MB1's Avatar
    Join Date
    Jan 2004
    Posts
    21,910

    Lots of lube on the seat clamp and careful with WD40 on the nose hardware.

    Just make sure to keep the WD40 off the leather.
    Quote Originally Posted by the_dude
    these are better than i was expecting, and my expectations were already rather high.

  5. #5
    Have a nice day
    Reputation: undies's Avatar
    Join Date
    Oct 2005
    Posts
    5,893
    Huh. I thought they were supposed to creak. Part of the character, etc.

    Proof once again that lubrication is the key.

  6. #6
    RoadBikeReview Member
    Reputation:
    Join Date
    Dec 2005
    Posts
    7
    When I got home to look at the saddle, it seemed that entire frame was creaking and not just the rails ... I sprayed some WD40 on the clamp and tightened up the tension bolt 2 turns ... perfect! .... thanks ....

  7. #7
    RoadBikeReview Member
    Reputation:
    Join Date
    Feb 2006
    Posts
    728
    I have 3 B17's that eventually always start creaking in the bolt contraption. I spray a little lube in the lower part where the rail is in the U part and it goes away, for a while, then returns. Kind of annoying...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

THE SITE

ABOUT ROADBIKEREVIEW

VISIT US AT

© Copyright 2020 VerticalScope Inc. All rights reserved.