• 11-14-2013
    rabochuffo
    3 Attachment(s)
    Red exogram crank cracking/ loose pedal insert
    Has anyone else had issues with the sram red exogram cranks cracking and showing visible delam around the pedal insert?
    the cracking is on the downstroke side of both crank arms.



    Attachment 288879Attachment 288880Attachment 288881
  • 11-14-2013
    rabochuffo
    1 Attachment(s)
  • 12-01-2013
    Merckx Ti
    Quote:

    Originally Posted by rabochuffo View Post

    A friend of mine had a Force crankarm do that a month ago.
  • 02-15-2014
    Barts27
    Hi, It happend to my Sram Red Crankset 2012 model left crankarm. I heared the sound of a crack today and when I got home and cleaned my bike I saw the crack at the exact same spot as on your pictures.
  • 02-15-2014
    bikerector
    I had this happen on the left arm as well, also cracked the aluminum insert. Mine was the 2012 crank I think, so 1 year before exogram.
  • 02-15-2014
    Barts27
    Did you contact Sram about it?
  • 02-15-2014
    bikerector
    Quote:

    Originally Posted by Barts27 View Post
    Did you contact Sram about it?

    I was just told that it was out of warranty and that I could buy a new one. The non-drive arm is more expensive than a new take off rival crankset, so I just bought a whole new crank so I could start using my stages on the road bike as well as my cross bike.

    I didn't gather any more info than that, I'm not sure how common it is or anything. It's not the first less than normal thing I've broken on a bike so we just chalked it up to me being a big dumb animal on a bike.
  • 02-17-2014
    rabochuffo
    Quote:

    Originally Posted by bikerector View Post
    I was just told that it was out of warranty and that I could buy a new one. The non-drive arm is more expensive than a new take off rival crankset, so I just bought a whole new crank so I could start using my stages on the road bike as well as my cross bike.

    I didn't gather any more info than that, I'm not sure how common it is or anything. It's not the first less than normal thing I've broken on a bike so we just chalked it up to me being a big dumb animal on a bike.

    I would still contact sram about this!!! It is clearly a common problem. I mentioned this to some of the guys I ride with and it has been seen before! suppose to be a bad batch....
  • 02-18-2014
    bikerector
    Quote:

    Originally Posted by rabochuffo View Post
    I would still contact sram about this!!! It is clearly a common problem. I mentioned this to some of the guys I ride with and it has been seen before! suppose to be a bad batch....

    My LBS contacted SRAM directly about this and what I typed was SRAM's response. I'm sponsored by the LBS so I consider the information from them pretty reliable. Maybe they consider it a wear item, I'm not sure. Sram has been pretty good about other warranty items but I don't feel they're obligated to replace this. I do hope they are working on fixing the problem though if there are so many of these occurrences happening.